Protokoll der Zerstörung

Am Samstag gab es hier ein Gewitter. Unabhängig davon, dass einer der FIs ca. 5-10x ausgelöst hat und ich dementsprechend oft runterlaufen musste, um den wieder reinzudrücken und zeitweise der Strom ganz weg war, sodass die USV von meiner Workstation und von meinem Server letztenendes auch kapitulieren mussten hat es dabei schließlich auch noch die TK-Anlage, den NTBA sowie die FritzBox dahingerafft. Momentan läuft das meiste notdürftig wieder, Internetzugang läuft über meinen alten Router (den ich seinerzeit ausgebaut habe, weil er instabil wurde – was dato immer noch der Fall ist), Telefon geht an manchen Ports noch über die alte Anlage (nein, meine gehen alle nicht mehr), daher habe ich meine Rufnummer direkt aufs Mobiltelefon weitergeleitet.

Sehr ärgerlich, das alles, da ich gerade alles so schön am laufen hatte. Immerhin gibts vorraussichtlich morgen die neuen Sachen, u.a. ne neue TK-Anlage die jetzt direkt VoIP kann. Dazu morgen mehr.

Hier der jetzige Zustand, alles ein wenig zerrupft. (Ja, man kann den Kram auf dem letzten Bild auch alles halbwegs ordentlich in den Netzwerkschrank tun, aber wenn man das Zeug ständig neustarten muss, dann lässt man das irgendwann bleiben…)

Die wunderbare Welt der Treiber

Seit gestern habe ich ein neues Telefon. Um genau zu sein, ein Siemens OpenStage 60 SIP. Ich bin bisher sehr zufrieden damit.

Als SIP2ISDN Gateway nutze ich meine FRITZ!Box 7270, die gleichzeitig mein Internet-Gateway ist. Nach anfänglichen Hakeleien beim Anmelden des Telefons ging es dann auch irgendwann und bisherige Tests waren sehr zufriedenstellend bzgl. Sprachqualität und Features.

Nun wollte ich noch die TAPI Schnittstelle der FRITZ!Box aktivieren, um vom Rechner aus bspw. aus Outlook Anrufe starten zu können. Nachdem ich meinen Rechner auf Windows 7 umgestellt hatte, ging das mit meinem alten Telefon, einem T-Concept PX721, leider nicht mehr. Diese Überlegung sollte ich jedoch schon bald bereuen. Die Installation des Treibers klappte problemlos, es war jedoch auch nach diversen Recherchen nicht möglich, in der CTI-Applikation die TAPI-Schnittstelle der FRITZ!Box auszuwählen. Wie verschiedenste Webseiten schreiben, hat AVM es offenbar bis heute nicht für nötig befunden, einen funktionierenden 64bit-Treiber für die FRITZ!Box-TAPI-Schnittstelle zu entwickeln. Lieber begnügen sie sich damit, in der info-Datei des Treibers auf die 32bit-only-Kompatibilität hinzuweisen. Ich finde das AVM hier ein recht armseliges Bild abgibt, wenn rund 8 Monaten nach der Markteinführung von Windows 7 und mehr als 3 Jahre nach der Markteinführung von Windows Vista für die 64bit-Version beider Systeme nicht einmal Beta-Versionen von Treibern existieren und man andererseits vollmundig behauptet, die FRITZ!Box sei geradezu für Windows 7 gemacht.

Nach dem nicht veränderbaren DNS-Eintrag des integrierten DHCP-Servers (der immer die FRITZ!Box selber und damit den (geforwardeten) Provider-DNS ausliefert) und einem weiteren Punkt, der mir gerade entfallen ist, schon das dritte Mal, dass ich mich maßlos über die Kiste geärgert habe.